Package Details: ffmpeg-full 3.4.2-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-full.git (read-only)
Package Base: ffmpeg-full
Description: Record, convert and stream audio and video (all possible features including nvenc, qsv and libfdk-aac)
Upstream URL: http://www.ffmpeg.org/
Keywords: audio codec convert cuda cuvid decklink encoder fdk-aac fdkaac ffmpeg hwaccel libnpp media nvenc qsv quicksync vaapi video
Licenses: custom: nonfree and unredistributable
Conflicts: ffmpeg, ffmpeg-decklink, ffmpeg-full-git, ffmpeg-full-nvenc, ffmpeg-git, ffmpeg-libfdk_aac, ffmpeg-nvenc, ffmpeg-qsv-git, ffmpeg-semifull-git
Provides: ffmpeg, ffmpeg-decklink, ffmpeg-full-nvenc, ffmpeg-libfdk_aac, ffmpeg-nvenc, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so, qt-faststart
Submitter: rpolzer
Maintainer: dbermond
Last Packager: dbermond
Votes: 65
Popularity: 1.182502
First Submitted: 2013-01-24 11:17
Last Updated: 2018-02-12 16:53

Dependencies (90)

Required by (714)

Sources (4)

Latest Comments

dbermond commented on 2018-02-06 19:39

@friday13 This is normal and expected because libvpx 1.7.0 increased the library version number.

Do a system upgrade with -Syudd to ignore dependencies. After this, recompile ffmpeg-full.

friday13 commented on 2018-02-06 19:13

resolving dependencies... looking for conflicting packages... error: failed to prepare transaction (could not satisfy dependencies) :: ffmpeg-full-nvenc: installing libvpx (1.7.0-1) breaks dependency 'libvpx.so=4-64' @dbermond

dbermond commented on 2018-01-16 16:12

@keepitsimpleengr This is normal since package depends on libx264.so.

Just follow @MichaelChou advice when dealing with libx264 and libx265 upgrades.

MichaelChou commented on 2018-01-13 10:29

@keepitsimpleengr

You can upgrade libx264 with -d to ignore dependency version checking. Then rebuild ffmpeg-full against the newly install libx264.

keepitsimpleengr commented on 2018-01-12 18:39

ffmpeg-full: installing libx264 (2:152.20171224-1) breaks dependency 'libx264.so=148-64'

libx264-10bit 2:152.20171224-1

keepitsimpleengr commented on 2018-01-12 18:38

ffmpeg-full: installing libx264 (2:152.20171224-1) breaks dependency 'libx264.so=148-64'

libx264-10bit 2:152.20171224-1

dbermond commented on 2018-01-07 23:37

@3ED_0 It seems that you have an outdated version of rockchip-mpp.

Please update rockchip-mpp to the latest version (currently at 20171218) and try again.

3ED_0 commented on 2018-01-07 23:24

[...] -> Running ffmpeg configure script. Please wait... ERROR: rockchip_mpp >= 1.3.7 not found using pkg-config [...]

Aur: rockchip-mpp

dbermond commented on 2017-11-09 18:01

@FallenSnow
Thank you for reporting this. Fixed.

FallenSnow commented on 2017-11-06 00:47

If arch is not x86_64 the ./configure script throws an error because "$_ldflags" is not defined.

All comments