Package Details: ffmpeg-libfdk_aac 1:3.4.2-1

Git Clone URL: https://aur.archlinux.org/ffmpeg-libfdk_aac.git (read-only)
Package Base: ffmpeg-libfdk_aac
Description: Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)
Upstream URL: http://ffmpeg.org/
Licenses: GPL3, custom:libfdk-aac
Conflicts: ffmpeg
Provides: ffmpeg=3.4.2, libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavresample.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so
Submitter: korrode
Maintainer: bwidawsk
Last Packager: bwidawsk
Votes: 42
Popularity: 1.816009
First Submitted: 2013-07-12 10:24
Last Updated: 2018-02-13 02:19

Dependencies (49)

Required by (713)

Sources (3)

Latest Comments

wookietreiber commented on 2017-12-22 16:41

Yes, but there is only one AUR and the https://archlinux32.org/ people want this package, too.

bwidawsk commented on 2017-12-22 16:09

32b packages are no longer supported on Arch and this matches the upstream PKGBUILD:

commit c3575ef3241db32a1a07df2e9a9ca85044637406
Author: foutrelis foutrelis@eb2447ed-0c53-47e4-bac8-5bc4a241df78
Date:   Wed Nov 15 14:11:34 2017 +0000

Remove i686 from arch=()

git-svn-id: file:///srv/repos/svn-packages/svn@310007 eb2447ed-0c53-47e4-bac8-5bc4a241df78

diff --git a/trunk/PKGBUILD b/trunk/PKGBUILD index 63d0d5b..875cf73 100644 --- a/trunk/PKGBUILD +++ b/trunk/PKGBUILD @@ -10,7 +10,7 @@ pkgver=3.4 pkgrel=4 epoch=1 pkgdesc='Complete solution to record, convert and stream audio and video' -arch=('i686' 'x86_64') +arch=('x86_64') url='http://ffmpeg.org/' license=('GPL3') depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'

Shywim commented on 2017-12-22 11:38

Why remove i686 from the arch array? It's still correctly building.

wookietreiber commented on 2017-10-13 12:21

I found the reason for my previously posted build error:

```
/usr/bin/ld: /tmp/ccBJEF8M.ltrans6.ltrans.o: relocation R_X86_64_PC32 against undefined symbol `bF8' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
make: *** [library.mak:94: libswscale/libswscale.so.4] Error 1
```

This package does not compile with LTO. Does anyone else have this experience?

These are my flags:

```bash
CPPFLAGS="-D_FORTIFY_SOURCE=2"
CFLAGS="-march=native -mfpmath=sse -O2 -flto -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
CXXFLAGS="-march=native -mfpmath=sse -O2 -flto -pipe -fstack-protector-strong --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
LDFLAGS="-flto -Wl,-O1,--sort-common,--as-needed,-z,relro"
```

When I remove the `-flto` flags, it compiles just fine.

Maybe, if others also have these problems, it would be worth to remove `-flto` in `PKGBUILD`.

Martchus commented on 2017-08-16 16:58

Likely this package also needs ffmpeg-openjpeg2.2.patch, see https://git.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/ffmpeg

Martchus commented on 2017-08-14 18:28

@wookietreiber Is your build environment up-to-date? Might be related to https://www.archlinux.org/todo/pie-rebuild.

wookietreiber commented on 2017-08-14 18:18

hi, getting build error:

/usr/bin/ld: /tmp/ccl0iIfC.ltrans6.ltrans.o: relocation R_X86_64_PC32 against undefined symbol `bF8' can not be used when making a shared object; recompile with -fPIC
/usr/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
make: *** [library.mak:94: libswscale/libswscale.so.4] Error 1

any help appreciated

gourdcaptain commented on 2017-08-14 00:32

This has a build dependency on hardening-wrapper, which is no longer available in the official or AUR Repoes.

Batou commented on 2017-04-29 04:12

@bwidawsk: Thank you for the info and hard work you put into maintaining this package! Hope things stabilize soon so I can switch back.

bwidawsk commented on 2017-04-28 18:12

@Batou: blame x265. All packages relying on x265 should have the same problem.

All comments