Package Details: freac_cdk 1.1alpha_20171119-3

Git Clone URL: https://aur.archlinux.org/freac_cdk.git (read-only)
Package Base: freac_cdk
Description: Component development kit for freac.
Upstream URL: http://www.freac.org/
Licenses: GPL2
Submitter: FSMaxB
Maintainer: FSMaxB
Last Packager: FSMaxB
Votes: 5
Popularity: 0.093022
First Submitted: 2017-03-24 02:01
Last Updated: 2017-12-11 15:03

Latest Comments

uwechris commented on 2018-02-12 13:42

Uninstall of all the both packages (and automatically also the package smooth) helped (Thanks FSMaxB for your helping comment in package freac)

uwechris commented on 2018-01-30 13:50

I cannot install aur/freac 1.1alpha_20171119-1 and aur/freac_cdk 1.1alpha_20171119-3 because I get lot's of error messages like: common/metadata/picturedata.cpp: In member function 'smooth::Int BoCA::PictureData::Size() const': common/metadata/picturedata.cpp:43:2: error: 'Lock' was not declared in this scope Lock lock(mutex); ^~~~ or common/metadata/picturedata.cpp: In member function 'smooth::Int BoCA::PictureData::Size() const': common/metadata/picturedata.cpp:43:2: error: 'Lock' was not declared in this scope Lock lock(mutex); ^~~~

FSMaxB commented on 2017-12-11 15:08

I changed the smooth dependency to >=0.8.73.0. For now when upgrading you probably have to remove freac, freac_cdk and smooth and then install all of them again. There is no way I can think of that the dependencies can be properly updated any other way.

This should improve in the future as I plan to switch from the snapshot releases to the stable releases of freac once 1.1 is out.

uwechris commented on 2017-12-11 14:40

freac_cdk: installing smooth (0.8.73.0-1) violates dependency on 'smooth> = 0.8.73.0_pre4' - can you fix it please, thanks in advance.