Package Details: gifski 0.8.0-2

Git Clone URL: (read-only)
Package Base: gifski
Description: GIF encoder based on libimagequant (pngquant, gifquant?). Squeezes maximum possible quality from the awful GIF format
Upstream URL:
Keywords: gif
Licenses: AGPL3
Submitter: phw
Maintainer: phw
Last Packager: phw
Votes: 6
Popularity: 1.190914
First Submitted: 2017-11-03 17:03
Last Updated: 2018-02-05 16:25

Latest Comments

erbridge commented on 2018-03-15 07:59

I am having the same build issue as @ronjouch:

   Compiling ffmpeg-sys v3.4.1 (<>)
error: unexpected close delimiter: `]`
    --> /var/cache/pacman/pkg/gifski11568/gifski/src/gifski-0.8.0/target/release/build/ffmpeg-sys-6834f9cfd3cacc7e/out/
3074 | #[derive(Copy, Clone)]; 4usize ] , _bindgen_union_align : u32 , }#[test]
     |                                ^

error: Could not compile `ffmpeg-sys`.

I have ffmpeg installed.

ronjouch commented on 2017-11-26 15:17

@phw quick heads-up: gifski-0.6.2-2 x64 now builds fine on my machine (with yaourt), and is usable from peek :) . Thanks for the work!

phw commented on 2017-11-06 06:42

@ronjouch: Still can't reproduce, also tried both 64 and 32bit builds. But anyway, I disabled the video decoding support, that fixes the 0.5.0 build error and should also fix your issues. That feature is highly experimental anyway and still has some bugs.

ronjouch commented on 2017-11-05 23:39

@phw exact same build failure with gifski-git.

Answering your ffmpeg question: no, nothing special, it's the official ffmpeg-3.4-1 from the [extra] repo (I'm on my home machine, it's not the static build I use on my work machine that I mentioned over at ). It's also regular rust+cargo from the repos, no rustup.

phw commented on 2017-11-05 21:33

@ronjouch I cannot reproduce this, can build both locally and in a chroot environment. Does the newest 0.5.0 release fix it? Do you have ffmpeg installed from Arch repositories or is there anything special with it? Maybe also try gifski-git

UPDATE: Sorry, I did not push the latest 0.5.0. A different build error in gifski itself there. As this tool is currently under very active development I would recommend to use gifski-git. That builds fine for me.

ronjouch commented on 2017-11-05 17:25

@phw build fails with:

Compiling ffmpeg-sys v3.4.0 (
error: unexpected close delimiter: `]`
--> /tmp/yaourt-tmp-ronj/aur-gifski/src/gifski-0.4.0/target/release/build/ffmpeg-sys-87999cd4eeb9a82e/out/
2997 | #[derive(Copy, Clone)]; 4usize ] , _bindgen_union_align : u32 , }#[test]
| ^

error: Could not compile `ffmpeg-sys`.

To learn more, run the command again with --verbose.