Package Details: gimp-devel 1:2.10.0_rc2-1

Git Clone URL: https://aur.archlinux.org/gimp-devel.git (read-only)
Package Base: gimp-devel
Description: GNU Image Manipulation Program (Development version)
Upstream URL: http://www.gimp.org/
Licenses: GPL, LGPL
Conflicts: gimp
Provides: gimp=2.10.0_rc2
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 11
Popularity: 0.534980
First Submitted: 2017-02-02 23:39
Last Updated: 2018-04-18 03:59

Dependencies (35)

Required by (148)

Sources (2)

Latest Comments

rafaelff commented on 2018-04-16 10:43

@twa022: the 'provides' array should end up like gimp=2.10.0, but since pkgver contains 'rc1' the 'provides' is currently gimp=2.10.0rc1; I recommend using pkgver=2.10.0, adding an extra variable _rc=-RC1 and use version like ${pkgver}${rc} instead, and 'provides' array would be fixed.

magnade commented on 2018-04-01 01:55

anyone hitting bug like: https://bugzilla.gnome.org/show_bug.cgi?id=794818 make sure to recompile libmypaint

sekret commented on 2018-03-29 13:47

Error: GIMP configuration failed.

  • Error: missing dependency poppler-data >= 0.4.7

Please add poppler-data to makedepends.

bm456 commented on 2018-03-28 18:24

Updated to 2.10.RC1 https://p.teknik.io/E1Peq

donny commented on 2018-01-06 04:09

If gimp argues about missing libjson-c.so.2 after update of core/json-c, rebuild the dependent package "libmypaint".

sekret commented on 2017-12-27 13:27

Please add glib-networking to makedepends, otherwise the package doesn't build.

SinClaus commented on 2017-12-16 07:01

@twa022 Thanks, I'v installed babl/gegl from git and they are with right version numbers, but yaourt don't know about this, it know about old versions only.

$ yaourt -Ss babl-git

aur/babl-git 0.1.30.42.gcc29a76-1 [installed: 0.1.38.23.g5aa4a51-1] (106) (0.86)

babl is a dynamic, any to any, pixel format translation library.

SinClaus commented on 2017-12-15 02:40

Yes, I can modify, but developer think something when say about dependencies.

maderios commented on 2017-12-14 14:14

@SinClaus You have to modify dependencies in PKGBUILD. I built gimp-devel 2.9.8 with babl-git and gegl-git. It works fine.

twa022 commented on 2017-12-14 14:01

@SinClaus: the pkgver for babl-git and gegl-git will be updated at build time. Build and install those packages in that order, them gimp-devel. If you feel comfortable editing the official babl and gegl PKGBUILDs, both required versions have been released by developers just not yet packaged by the arch packagers yet.

All comments