Package Details: gitkraken 3.5.1-1

Git Clone URL: https://aur.archlinux.org/gitkraken.git (read-only)
Package Base: gitkraken
Description: The intuitive, fast, and beautiful cross-platform Git client.
Upstream URL: https://www.gitkraken.com/
Keywords: git
Licenses: custom
Provides: gitkraken
Submitter: Azd325
Maintainer: Azd325 (MarcinWieczorek)
Last Packager: Azd325
Votes: 192
Popularity: 4.545553
First Submitted: 2015-10-21 19:17
Last Updated: 2018-04-06 05:30

Pinned Comments

Azd325 commented on 2016-12-06 23:45

Hey guys,
If you want to speed up/improve the process there is also a GitHub repo availaible to do PRs :)
https://github.com/Azd325/gitkraken

Thanks
Tim

Latest Comments

BrianAllred commented on 2018-03-14 18:47

@Azd325 @omouren

Ah, I didn't realize I had installed this from the Antergos repo. I'll reinstall from the AUR, should fix it. Thanks.

Azd325 commented on 2018-03-14 16:30

@BrianAllred There is no LD_PRELOAD since last release. ;)

BrianAllred commented on 2018-03-14 16:27

Running the binary straight from /opt/gitkraken worked for me. Maybe the LD_PRELOAD is no longer necessary?

omouren commented on 2018-03-14 14:31

/opt/gitkraken/gitkraken: error while loading shared libraries: libpsl.so.5: cannot open shared object file: No such file or directory Antergos, since Gitkraken 3.4.0-1

Azd325 commented on 2018-03-12 20:20

@dann1 Do you have the lastest updates and libcurl-gnutls installed?

dann1 commented on 2018-03-12 19:01

Hello, gitkraken cannot start

/usr/lib/libssl.so.1.0.0: version OPENSSL_1.0.2d' not found (required by /usr/lib/libcurl-openssl-1.0/libcurl.so.4) Error: /usr/lib/libssl.so.1.0.0: versionOPENSSL_1.0.2d' not found (required by /usr/lib/libcurl-openssl-1.0/libcurl.so.4) at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:173:20) at Object.Module._extensions..node (module.js:598:18) at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:187:18) at Module.load (module.js:488:32) at tryModuleLoad (module.js:447:12) at Function.Module._load (module.js:439:3) at Module.require (module.js:498:17) at require (internal/module.js:20:19) at Object.<anonymous> (/opt/gitkraken/resources/app.asar/node_modules/nodegit/dist/nodegit.js:11:12) at Object.<anonymous> (/opt/gitkraken/resources/app.asar/node_modules/nodegit/dist/nodegit.js:1031:3)</anonymous></anonymous>

EgidioCaprino commented on 2018-03-01 15:34

yaourt -S gitkraken [sudo] password for egidio: resolving dependencies... warning: cannot resolve "libcurl-openssl-1.0", a dependency of "gitkraken" :: The following package cannot be upgraded due to unresolvable dependencies: gitkraken

:: Do you want to skip the above package for this upgrade? [y/N] error: failed to prepare transaction (could not satisfy dependencies) :: gitkraken: requires libcurl-openssl-1.0

zython commented on 2018-02-28 12:51

Anyone else experiencing a segfault with LD_PRELOAD and an 'CURL_OPENSSL_3' not found without it ?

Update: a mix of frustration, a system upgrade, some reinstalling of gikraken and a variety of dependencies, and a little bit of magic/miracle fixed the issue.

Honestly I have no idea what fixed this.

kikadf commented on 2018-02-27 18:05

@Azd325: thx, works fine.

Azd325 commented on 2018-02-26 17:15

Which libcurl-gnutls version you have?

I changed to LD_PRELOAD=/usr/lib/libcurl-gnutls.so.3

All comments