Package Details: icaclient 13.8-1

Git Clone URL: https://aur.archlinux.org/icaclient.git (read-only)
Package Base: icaclient
Description: Citrix Receiver for x86_64 (64bit) Linux (ICAClient)
Upstream URL: https://www.citrix.com/products/receiver/
Licenses: custom:Citrix
Conflicts: bin32-citrix-client, citrix-client
Submitter: wmarshall
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 98
Popularity: 0.910481
First Submitted: 2011-12-08 18:49
Last Updated: 2017-12-08 20:11

Pinned Comments

fordprefect commented on 2017-03-06 21:27

Update for 13.5 - please test carefully before using in production.
gstreamer0.10 is now an opt-dependency as discussed here.
If you find any glitches please report.

EDIT: if you want blindly updating and complaining about non-functioning afterwards you should stick to official packages!

Latest Comments

Lindhe commented on 2018-02-12 11:14

After installing, it says "You have to create '$HOME/.ICAClient/cache' for each user who uses this program and then populate it with the appropriate ini files. Copy paste the below to do this easily" but that is actually incorrect. With that phrasing, it sounds like the cache directory should be populated with the .ini files, while in fact it is the ~/.ICAClient directory that should be populated.

lelepuntocom commented on 2018-01-07 09:39

Any news to solve ssl error? 13.8 for me always the same error...

fordprefect commented on 2017-10-11 19:42

@ccoffey: I don't use this at all (anymore). I stated this fairly often: I am just updating this package when a new version comes along, but I don't even have a citrix server to my avail. If anyone is interested to take over just tell.

ccoffey commented on 2017-10-11 19:35

Juxt curious, what do you use the plugin for?
It's a few years since I worked in citrix, but everytime, we'd just disable the plugin, and download the ica file, and set FF to open it with icaclient.

fordprefect commented on 2017-10-11 19:31

@birdspider: use Firefox ESR with this, that should work. In the long run, Citrix has to do something about it, I am not aware of any news regarding any porting work though.

birdspider commented on 2017-10-11 14:26

FF 52 removed NPAPI (https://www.mozilla.org/en-US/firefox/52.0/releasenotes/) - is this package/plugin (/usr/lib/mozilla/plugins/npica.so) supposed to work with newer versions (FF 52+)?

nutz commented on 2017-08-27 18:29

thanks erkexzcx for the 13.4 built.

i created this here for easier access:
https://aur.archlinux.org/packages/icaclient-old

JetJaguarXP commented on 2017-08-24 06:36

Thank you for this package!

Jet

jamesbond007 commented on 2017-07-12 17:11

When I try to install this, I get the following error message:

==> ERROR: One or more files did not pass the validity check!

erkexzcx commented on 2017-06-05 19:37

For those who want to have icaclient 13.4 (this version does not have "unable to type anything" issue) without future updates and gstreamer0.10 (since not needed) from the AUR, here is how to install it:

$ sudo pacman -S wget dos2unix git
$ git clone https://aur.archlinux.org/icaclient.git/
$ cd icaclient
$ git checkout 103eefa32a36c95acc779ca172b6acb99d909aa2
$ wget https://www.pastebucket.com/paste/download/562435 -O PKGBUILD
$ dos2unix PKGBUILD
$ makepkg -si

All comments