Package Details: kiwix-bin 0.9-3

Git Clone URL: https://aur.archlinux.org/kiwix-bin.git (read-only)
Package Base: kiwix-bin
Description: Offline reader for Web content. It's especially intended to make Wikipedia available offline.
Upstream URL: http://www.kiwix.org
Licenses: GPL3
Conflicts: kiwix
Provides: kiwix
Submitter: felihommen
Maintainer: nic96
Last Packager: nic96
Votes: 37
Popularity: 1.829618
First Submitted: 2012-03-30 11:14
Last Updated: 2017-10-10 19:16

Latest Comments

nic96 commented on 2017-10-10 19:18

@Asher256: Done

Asher256 commented on 2017-09-09 15:30

@THS: thanks for the fix.

@to the maintainers 'nic96' and 'felihommen': it could be interesting to add "ln -sf /usr/lib/libz.so.1 /usr/lib/kiwix/xulrunner/libz.so.1" + 'zlib' dependency to the PKGBUILD, to fix the issue reported in the comments permanently (the issue: "/usr/lib/kiwix/xulrunner/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16...").

stardiviner commented on 2017-08-11 01:04

@THS , thanks your workaround. That fix my problem.

THS commented on 2017-07-27 16:11

If you want to get the this version working just replace the libz.so.1 with the current one.

sudo ln -sf /usr/lib/libz.so.1 /usr/lib/kiwix/xulrunner/libz.so.1

Now Kiwix is functional again.

nobicycle commented on 2017-07-08 07:53

I confirm the report by
kahredici2 commented on 2017-05-01 00:15

Also confirm the workaround by:
chbinnc commented on 2017-04-23 10:23

Regards

chbinnc commented on 2017-06-02 07:21

I try kiwix-cli-git from https://aur.archlinux.org/packages/kiwix-cli-git/ and it works very well. It uses the new official repository on github https://github.com/kiwix/kiwix.
Tip: You can just start kiwix with `$ kiwix-serve --port=2222 Zimfile1 Zimfile2` and open it with 127.0.0.1:2222 in browser. For other parameters please check --help.

kahredici2 commented on 2017-05-01 00:15

XPCOMGlueLoad error for file /usr/lib/kiwix/xulrunner/libxul.so:

/usr/lib/kiwix/xulrunner/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)

Couldn't load XPCOM.

chbinnc commented on 2017-04-23 10:23

@anton-tsyganenko I downgrade libpng from 1.6.29 to 1.6.28 and it works, also I tried to directly compile kiwix from source but failed.

anton-tsyganenko commented on 2017-04-16 12:26

I can't run both this package and the executable file from the official website:

XPCOMGlueLoad error for file /usr/lib/kiwix/xulrunner/libxul.so:
/usr/lib/kiwix/xulrunner/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)
Couldn't load XPCOM.

kralyk commented on 2017-01-07 12:57

@nic96 Thanks for the quick fix!

All comments